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 AGILENT ADS
TUTORIAL

ABSTRACT

The purpose of this tutorial is to help you get started with using Agilent’s Advanced Design System located on all the Sun
workstations.  The tutorial describes how to start ADS, create an RF network to be analyzed, run simulations, layout an analyzed
network, and use some optimization techniques.  For more advanced design topics not found in this tutorial, please consult the
on-line manuals at http://www.agilent.com/eesof-eda (refer to the posted Agilent ADS technical support information for how to

access the on-line manuals).  Or you may use the hard copy manuals located in the RF lab in Jobst 325, but please do not remove
them from the lab.

This tutorial was started by Sasidar Vaja in 1999.
It was supplemented, updated, and modified by Scarlet Halabi in 2000 and 2001.
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1 STARTING HP-ADS

1.1 Login to a Sun Work Station:

You may use any Sun workstation: cegt202, 203, 204, 205, 206, 207, 208, 209, 210, or 211.

For first time Sun users: Use your login alias for user name, and type s + the last six digits of your SSN.  Then a window
inquiring which desktop environment to use pops up.  By default, the Common Desktop Environment (CDE) is chosen.  If
CDE is not chosen, choose it and click OK.

1.2 Starting HP-ADS:

ADS must be opened via a terminal window.  To open a terminal window, right click on the screen and select Hosts>This Host.
Then a terminal window appears.

For first time ADS users: In the terminal window at the prompt, create a folder called “ads” (or ADS) by typing “mkdir ads”.
Then type “cd ads” to work in the ads directory.  In the ads folder, type hpads at the prompt and press Return to start the ADS
program.  The Advanced Design System Setup dialog box will appear.  The default selection is Both, With Default:
Analog/RF Design.  If this is not selected, please choose it and click OK. Then the Advanced Design System Main window
appears. an Important Information window opens as a Readme file.  You may read it and choose Don’t Display This Again,
and click OK.

For NON-first time ADS users: In the ads folder, type hpads at the prompt and press Return to start the ADS program.  Then
the Advanced Design System Main window appears.

Through the main window, you can work with projects already existing or create new projects.  Projects are central to the
operation of all the simulators and allow you to organize your related designs.

1.3 Creating a Project:

All design work must be done in a project directory.  Working in a project directory allows you to organize related files within a
predetermined file structure.  This predetermined file structure consists of a set of subdirectories that contain different types of
files.  These subdirectories are used in the following manner:
• networks contain schematic and layout information as well as information needed for simulating.
• data is the default directory location for input and output data files used or generated by the simulator.
• mom_dsn contains designs created with the HP planar electromagnetic simulator, Momentum.
• synthesis contains designs created with DSP filter and synthesis tools.
• verification contains files generated by the Design Rule Checker (DRC), used with layout.

1.3.1 Creating a New Project:
1. Choose File>New Project and a dialog box appears.  By default, the path is set to your start-up directory.
2. Provide a name for your new project e.g. projectname_prj.
3. Choose OK.  The path and the project name appear at the bottom of the main window.
4. By default, the schematic window is automatically displayed when you create a project.  You can start building your

schematic in that window – jump to section 2.3 to create a schematic.

Other ways of opening the design window are discussed in the next section.

1.3.2 Opening an Existing Project:
You may open an existing project using the tree-like structure (File Browser) or you may use File>Open Project.  Once a project
is opened, its path and name are displayed in the status panel of the main window.

To open a project using the tree-like structure (File Browser):
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1. Double-click as needed in the File Browser section of the Main Window to display the desired project directory.
2. When the desired project is listed, under the heading Project Listing, double-click to open it. The contents of the project

directory are displayed, or an empty schematic window opens.

To open a project using the File Menu:
1. In the Main window, choose File>Open Project.
3. In the dialog box that appears, double-click as needed to locate the desired directory and then double-click to open it. The

contents of the project directory are displayed, or an empty schematic window opens.

1.3.3 Exiting HP-ADS:
To exit from ADS, choose File>Exit Advanced Design System, and click OK in the dialog box.
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2 CREATION OF AN RF NETWORK

2.1 Opening a Schematic Design Window:

• To open a Schematic window for creating a new design or editing an existing design, click New Schematic icon or choose
Window>New Schematic from the ADS Main window.

• For an additional schematic window you may also do the same.
(As mentioned before, when you create a new project, by default, a design window automatically appears.)

2.2 Accessing a Design File:

You may choose to create a new design file for your RF network, or you may want to modify an existing design file.

2.2.1 Creating a New File:
• In the schematic window, choose File>New Design, or click on the Create A New Design button from the tool bar.
• Enter a relevant name in the name field.
• Since we are going to work on RF Networks, we will select design type as Analog/RF Network (default).
• Optional: select a Design Template to use as a starting point for your design (in most of the designs, you don’t need to select

this).
• Choose OK. The title of the existing window changes to reflect the new design name.

2.2.3 Opening an Existing File:
• Double click the file name in the tree-like structure in the Main widow under the “networks” folder.
• OR use File>Open Design command in the appropriate design window.
• OR click on the Open An Existing Design on the tool bar.

2.3 Creating a Schematic:

Before starting a schematic, it is important to define the default units. It can be defined by choosing
Options>Preferences>Units/Scale (use the side markers to get to Units/Scale).  Then choose the default or user-defined units
and select Apply, then OK.  Then start building your circuit.  There are two ways of selecting circuit components: using the
Component Palette and using the Component library.

2.3.1 Using the Component Palette:
The component palette, on the left side of each design window, contains buttons representing components to be placed in the
drawing area.  To select a category of components for the palette, select the desired category from the drop-down Component
Palette List.  You can also bring up the palette selection list as a dialog box by selecting View>Component>Select Component
Palette in the schematic window.  To use the palette to place items in the drawing area, follow these steps:
1. Choose the desired component palette category.  For example, if microstrip components are desired, TLines-Microstrip

from the palette list. Then, microstrip components such as lines, bends, tees, substrate etc. are displayed with self-explained
buttons for each component.  Balloon help is available to identify these icons.

2. Click on the button corresponding to the desired component.
3. Then move the pointer to the drawing area.  As you move the pointer into the drawing area, a ghost image of the symbol

moves with it.  Click the Rotate by -90 icon on the toolbar to rotate the symbol as needed, then click in the drawing area to
place the item in the desired location.  To end the command, i.e. remove the ghost image of the symbol, press the escape
<ESC> key; or you may right click anywhere in the schematic window and select End Command from the drop-down
menu.  (More information on rotating the components and editing component values/specifications is covered in sections
2.3.5 and 2.3.6).

2.3.2 Using the Component Library:
When you click the Display Component Library List button on the tool bar or when you choose
Insert>Component>Component Library, the component library dialog box appears displaying a list of libraries and the
components available in each library.  To use the component library to place items:
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1. After displaying the component library list, select the appropriate library from the library sub-window.  For example, select
TLines-Microstrip for microstrip elements, Lumped Components for resistors, inductors, capacitors, etc.

2. Then select the desired component from the component sub-window.
3. As you move the pointer to the viewing area, a ghost image of the symbol moves with it.  Click to place the component in the

drawing area, and press ESC to end the command.

2.3.3 Example 1, Lumped Circuit Elements (capacitors, inductors, resistors,…):
Click on the drop-down Component Palette List and different options will appear.  Select Lumped-Components.

Different buttons will appear which will represent various lumped components such as resistors, capacitors etc.  Select the
required component.  Move the cursor onto the drawing area.  A ghost image of the component will move along with the cursor.
Place the component in the desired location, and press ESC to end the command.

If you wish to change the orientation of the component, refer to section 2.3.5.  To change the component parameters, refer to
section 2.3.6.

2.3.4 Example 2, Microstrip Elements:
Click on the drop-down Component Palette List and different options will appear.  Select TLines-Microstrip.  Different

buttons will appear which will represent various microstrip components such as MLIN, MBEND, MTEE etc.  Select the required
component.  Move the cursor onto the drawing area.  A ghost image of the component will move along with the cursor.  Click to
place the component in the desired location, and press ESC to end the command.

If you wish to change the orientation of the component, refer to section 2.3.5.  To change the component parameters, refer to
section 2.3.6.

2.3.5 Rotating, Moving, Copying, and Deleting Components:
2.3.5.1 To rotate a component prior to placing it in the drawing area, use any of the following methods:
1. Click the Rotate by -90 button on the toolbar while the ghost image is active.  Each click rotates the item 90 degrees

counterclockwise (CCW),
2. Press <Ctrl>+R  (rotates the item 90 degrees CCW),
3. Or choose Edit>Rotate by –90 (rotates the item 90 degrees counterclockwise).

2.3.5.2 To rotate a component after placing it in the drawing area:
1. Select the component to be rotated, or highlight the section of circuit to be rotated.  Click the Rotate by -90 button on the

toolbar, choose Edit>Rotate by –90, or press <Shift>+R, and the component rotates 90 degrees CCW.
2. OR Click the Rotate button from the tool bar, choose Edit>Advanced Rotate/Mirror>Rotate, or press <Shift>+R.  This

option rotates the component by an arbitrary angle.  As you move the pointer in the drawing area, a ghost image of the
component moves with it. Click to position it in the desired orientation.

2.3.5.3 To move the components or circuits in the drawing area:
1.  Select (or highlight) the component be moved.  Click on the selected item and drag to the desired location, and then let go.
2.  OR select the component to be moved and click on the Move Using Reference Point, or vice versa.  As you move the

pointer in the drawing area, a ghost of cross wires moves along with it.  Choose a reference point and click.  Then a ghost
image of the component moves along with the pointer.  Move the ghost image to the desired location and click to place it.

3.  To move several components at once, select the first component, then press <Shift> and hold it while selecting however
many other components needed.  Then release <Shift> and click on the selected items and drag them, while holding the
click, to the desired location, and then release the mouse.  Or you may use the Move Using Reference Point option.  You
may also highlight as many components as needed by clicking on the drawing area and dragging the pointer, while holding
the click, to form a box around the desired components.  This highlights all components within the box formed.

2.3.5.4 To copy the components or a particular part of the circuit to some other location in the drawing area:
1. Select the component or part of the circuit to be copied (follow the instructions in step 3 of section 2.3.5.3 to select more

than one component) and click the Copy Using Reference Point button on the tool bar, or vice versa.  As you move the
pointer in the drawing area, a ghost of cross wires with the pointer appears.  Click on the component to be copied, a ghost
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image appears.  Drag the ghost image to the desired location, and then click to place it there.  Then press <ESC> to end the
command or deselect the Copy Using Reference Point button.

2. OR Select the component(s) to be copied and choose Edit>Copy.  Then choose Edit>Paste.  A ghost image appears as you
move the pointer in the drawing area.  Move the image to the desired location and click to place it there.  Then press <ESC>
to end the command.

2.3.5.5 To copy a component or part of the circuit to another design or schematic:
Select the component(s) to be copied.  Choose Edit>Copy.  Go to the other design and choose Edit>Paste. A ghost image

appears as you move the pointer in the drawing area.  Move the image to the desired location and click to place it there.  Then
press <ESC> to end the command.

2.3.5.6 To delete the components or part of the circuit from the drawing area:
1. Select the component or part of the circuit to be deleted.  Click the Delete button on the tool bar, and the highlighted

component(s) will be deleted.
2. OR select the Delete button from the tool bar.  As you move the pointer in the drawing area, a ghost of cross wires along

with the pointer appears. Click on the component or the part of the circuit to be deleted.  Then press <ESC> to end the
command or deselect the Delete button.

2.3.6 Editing Component Parameters:
The dialog box for editing component parameters is not displayed automatically after the component symbol is placed in the
drawing area.  Double-click on the desired component to display the dialog box for editing, choose Edit>Component>Edit
Component Parameters, right-click and choose Edit Component Parameters from the drop-down menu, or click on the Edit
Component Parameters button on the tool bar.  (To display the component parameters dialog box at the time you select a
component prior to placing it in the drawing area, choose Options>Preferences>Placement and select the option Component
Parameter Dialog)

The dialog box allows you to edit the component parameters:
1. Select the parameter you want to change.
2. Where applicable, enter a new value for the parameter.
3. Press the <Return> key.  The parameters’ list box is updated to reflect the new value.
4. Enable or disable the display of that parameter on the schematic as desired.
5. Click Apply.
6. Choose another parameter for editing or choose OK to dismiss the dialog box.

You may also edit a component’s parameters by double clicking on the displayed parameter value in the drawing area.  The
parameter value will change to red and a cursor will start blinking, prompting you to edit the value.  Press the <Return> key
when done, or click anywhere in the drawing area.

2.3.7 Connecting Components:
You can connect components with wires. For that,
1. Click the Insert Wire button on the tool bar, a ghost of cross wires along with a pointer appears.
2. Position the pointer on the pin at one end of the component and click.
3. Position the pointer on the pin of the other component and click. A wire is drawn between the specified points.
4. Press <ESC> to end the command when done, or click the Insert Wire button.

2.3.8 Saving the Schematic:
1. Click on File in the Schematic window.
2. Select Save Design and a confirmation window appears.  Or for a new design, select Save Design As, and save the design

with a new name.
3. Click OK to save the changes.

2.3.9 Closing the Design:
1. Click on File in the schematic window.
2. Select Close Design and the design closes.
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2.3.10 Closing the Window:
Click on the little horizontal bar in the upper left corner, and choose Close from the drop-down menu.  Or double click on

the little horizontal bar in the upper left corner, and the window will close.

2.3.11 Using Online Help:
The Help menu in the ADS main window offers several methods of accessing the help system.
• Clicking Help>Topics and Index takes you to the on-line help: manuals, examples, design-guides, etc.
• Clicking Help>What’s This? makes a question mark with a pointer appear.  Using this question mark pointer, click on Help

and the browser will open with a list of Topics and an Index.
• To access the manuals: Choose Help>Topics and Index.  This takes you to the on-line manuals.
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3 SIMULATION (TESTING)

3.1 Specifying the Simulator:

After the RF network is completed in the schematic design window, simulation and measurements can be performed in the same
window.  Before starting the simulation, you must specify the Simulator.  There are different simulators that are divided into
different categories, such as Simulation – S_Param, Simulation - DC, etc. that are given in the drop-down Component Palette
List.  Follow the example in section 3.2.1below.

Note: An S-parameter simulation requires termination ports.  The Termination components (available in the S-parameter
simulation palette as Term) should be used to define the input and output ports.  The input Term should be identified as Num=1,
and the output Term as Num=2.  These terminations must be added to the RF network before running a simulation.  They should
also be connected to ground.

3.2 Placing Simulator Components:

There are two ways of selecting simulator components: using the Component Palette and using the Component Library.

3.2.1 Using the Simulator Component Palette:
The palette, on the left side of each design window, contains buttons for quick placement of items in the drawing area. To select a
different category of components for the palette, use the drop-down Component Palette List.  You can also bring up the palette
selection list as a dialog box by selecting View>Component>Select Component Palette.

1. Choose the desired simulation category palette.  For example, if an S-parameter simulation is needed, select the Simulation
– S_Param category from the drop-down list.  Then the related simulation components such as S_Param, Sweep Plan, etc.
are displayed with self-explanatory buttons for each component.  Balloon help is available to identify these icons.

2. Click on the button corresponding to the desired component.  For the S-parameter simulation, choose the S_Param button
from the palette labeled with SP.

3. Then, move the pointer to the drawing area. As you move the pointer into the drawing area, a ghost image of the symbol
moves with it.  Click in the drawing area to place the item in the desired location.

Note that this component will not be a part of the actual circuit.  This is just to set up information for the testing parameters
of the circuit during simulation.  Therefore, after placing the SP simulator component in the schematic window for an S-
parameter simulation, you can specify and edit various parameters for the simulation such as frequency range, noise
parameters, Y-parameters, Z-parameters, etc.  This can be done by double clicking on the item in the schematic window, by
right-clicking on the selected item and choosing Edit Component Parameters from the drop-down menu, or by selecting
the component and choosing the Edit Component Parameter button from the tool bar.  Then a dialog box appears wherein
you can modify or specify various desired parameters for the simulation.  You may also edit the displayed parameters by
double clicking on the value itself.  The value will change to red and a cursor will start blinking, prompting you to edit the
value.  When done, press <Return> or click anywhere in the drawing area.

3.2.2 Using the Simulator Component Library:
When you click on the Component Library button on the tool bar or choose Insert>Component>Component Library, the
library list dialog box appears displaying a list of categories and the components available in each category.

1. Select the desired simulation library (for example, Simulation – AC, Simulation – DC, Simulation –S_Param etc.)
2. Then click on the desired component.
3. As you move the pointer to the viewing area, a ghost image of the symbol moves with it.
4. Place the component in the desired location in the drawing area.  Note that this simulator component is not a part of the

circuit, so it is not connected to any part of the circuit.  It is just to set up information for the parameters that are to be
simulated.

3.3 Launching the Simulation:
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By selecting Simulate>Simulation Setup before simulating, one can specify the name of the data set and the filename of the
Data Display where the data in the data set(s) is displayed.  The default is the same as that of the Schematic filename.  By
changing the data set name, one may obtain different types of simulations for the same circuit using the same Data Display.  Then
click Apply, and then choose Simulate to perform the simulation.  One can also select Simulate>Simulate from the menu bar or
the Simulate icon from the tool bar to perform a simulation, provided that the data set name and the Data Display filename are
appropriate.

When you launch the simulation, a new ADS window appears, which has a Status/Summary sub-window.  The simulation is
completed when Simulation finished is indicated in the bottom line of the Status/Summary field.  If the simulation is not
successful, Simulation finished with errors is indicated in the Status/Summary field.

In the Simulation Setup dialog box, one may choose to have the Data Display window automatically opened after completing
the simulation by selecting Open Data Display when simulation completes.

3.4 Displaying the Simulation Data:

When the simulation successfully finishes, ADS will automatically open the Data Display window with the name specified in the
Simulation Setup if the Open Data Display when simulation completes option is chosen in the Simulation Setup dialog box.
If you have selected not to open the Data Display window automatically, choose Window>New Data Display, or click on the
New Data Display Window icon. The Data Display window opens. This can be done either in the schematic window or in the
main ADS window.

Follow these steps to plot the simulated data:
1. The default data set whose simulation data is to be plotted will be that specified in the Simulation Setup in the schematic

window.  If a different data set is needed, select the appropriate data set from the Dataset drop-down list.
2. Click on the appropriate buttons on the left-hand-side, for example Rectangular Plot, Smith Chart, Polar Chart, List etc.

to draw different simulation data on different charts.  As you move the pointer in the drawing area, a ghost image of the chart
will appear moving along with the pointer.  Click at the desired location on the drawing area where you want to place the
chart.  A Plot Traces & Attributes window pops up on the screen.
OR you may also choose Insert>Plot from the menu bar.  As you move the pointer in the drawing area, a ghost image of the
chart will also appear.  Click at the desired location on the drawing area where you want to place the chart.  A Plot Traces &
Attributes window pops up on the screen.  In this case you may choose the type of plot by selecting the appropriate icon
(Rectangular Plot, Smith Chart, Polar Chart, or List) at the top of the Plot Traces & Attributes window.

3. Select the desired data that are to be plotted on the chart from the Datasets and equations column.  Use Add and Delete
buttons to select or deselect the desired parameters that are to be plotted on the chart.

4. Click OK.  In case of a Rectangular Plot, a Complex Data! window pops up inquiring how to display the data.  Choose
what is appropriate for your measurement and click OK.  Then click OK again in the Plot Traces & Attributes window,
and the desired data will be plotted.

5. Repeat the above procedure to plot different simulation data.

Note: If noise calculations are desired, then do the following: In the S-parameters “Edit Parameter Window” choose the Noise
tab.  In the noise display, select “Calculate Noise”.  This allows the simulator to include noise calculations during a simulation.
There are three noise figure parameters: nf(1), nf(2), and nf.  Choose nf(2) to plot the noise figure of the circuit.
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4 LAYOUT

4.1 Generating a Circuit Layout:

The circuit layout can be generated either by connecting various elements in the layout window itself or by generating the layout
from the schematic.  Creating the layout by connecting various elements in the layout window is similar to creating a schematic.
All the tool bars are similar and the exact same procedure for connecting the circuits should be followed except that all the
elements will be considered as layout elements.

To open a layout window, click on the New Layout Window button in the ADS main window, or select Window>New Layout.
To set the layout window units, select Options>Preferences and choose the Layout Units tab.  Then select the desired units.

4.1.1 Generating the layout from the schematic:
Note 1: Before generating the layout, if any lumped elements or data blocks exist in the circuit, it should be noted that the circuit
will be synchronized only up to the first lumped element or data block starting from port 1.  In other words, this feature can not
synchronize the lumped circuit elements or data blocks or other such elements.

Note 2: It should be noted that when the circuit is synchronized, we should not expect the generated layout to be exactly as it was
in the circuit file (schematic).  For example, if you connect different branches of a circuit using wires, then the simulator will
generate a layout which will have the elements overlapped. In such a case, use of T-sections or bends will help.

Note 3: The spaces needed for soldering the lumped elements in the layout will not be generated automatically.  It can be done
only after generating the layout.

1. Remove all the lumped elements and connect all the components through wires.  For example, if a circuit is designed using
microstrip elements, then, when the layout is to be generated, all the lumped elements must be removed and the microstrip
elements on either side of the lumped element should be connected using wires.

2. Choose Layout>Generate/Update layout.  The Generate/Update Layout dialog box appears.
3. Accept the default values for the starting component, as well as for X, Y, and Angle.  Click OK to close the dialog box and

generate the layout.
4. A status window appears to confirm the layout generated.
5. Also, the layout window appears with the layout of the schematic design.

An alternative to the above steps is by not removing the lumped elements from the circuit.  In this case, steps 2 through 5 are
only carried out.  The synchronizer will generate meaningless components that can be deleted.

When the layout is complete, any text, pin numbers, connections, and meaningless components must be removed since they are
unnecessary for the actual layout.  All that is needed is the microstrip layout.  To remove the unwanted symbols and text, perform
the following:
a) Choose Options>Layers and the Layer Editor dialog box pops up.
b) Select the Visibility tab, and deselect Vis for the silk_screen layer.  This will also deselect Sel.  Click Apply.  This removes

any text on the layout.  Then click OK.
Note: This also deselects the Sel and Vis for the silk_screen layer under the Basic tab in the Layer Editor dialog box.

c) Choose Options>Preferences and the Preferences dialog box pops up.
d) Choose the Pin/Tee tab and the Pin/Tee dialog is displayed within the Preferences dialog box.
e) Under the Visibility field deselect Connected Pins, Pin Numbers, and Pin Names.
f) Under the Size field, change the size for both the Pin and the Tee to zero (0).  Click Apply. This removes the pin

connections and numbers on the layout.  Then click OK.

Note: Any modification applied to a component parameter in the layout window must be implemented in the schematic window.
The new circuit must be simulated to verify the validity of the S-parameters or noise figure or any other simulated data that is
desired.
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Note: If the lumped elements have been removed, one must remember to include spaces for their location in the layout (refer to
Note 3 above).

4.1.2 Designing the layout and transferring it into a schematic:
1. To open the layout design window, click on the New Layout Window icon in the main ADS window, and the layout

window appears.
2. Opening a design file:

a) If you are starting a new design file:
i. Click on File in the layout design window.
ii. Select New Design and a new design window appears, or you may click on the Create A New Design button on the

tool bar.
iii. Type the name of the design.
iv. Select OK in the new design window.

b) If you want to open a previously designed file:
i. Click on File in the layout design window.
ii. Select Open Design and a list of files will appear, or use the Open An Existing Design button on the tool bar.
iii. Choose the filename and click OK in the file list window, and the previously designed circuit artwork appears in the

layout design window.
3. Building a network:

a) To place the circuit elements:
i. Click on the Component Palette List combo box.
ii. Choose the desired set of elements you need for your circuit.

Example:
If you need microstrip elements,
1- Click on the Component Palette List combo box on the left-hand side of the layout window.
2- Select TLines-Microstrip, a palette of all microstrip elements will appear.
3- Select the required component by selecting the corresponding icon.
4- Move the cursor to the layout window and a ghost image of the element appears.  At the same time, the parameter

editor box appears.  One can edit the parameter values before placing the component in the desired location in this
case.  Or you may do so later as explained in step 6.

5- Click the mouse to place the element at the desired location, and press <ESC> to end the command.
6- Double click on the element, a dialog box appears, wherein you can enter the values for various parameters.

b) Place all the elements and complete the design.  Make sure all components are connected, and do not remove any text,
symbols, or pin numbers.

4. Transfer the circuit element to the schematic window:
1- Select Schematic>Generate/Update Schematic.
2- Accept the default values for the starting component, as well as for X, Y, and Angle.  Click OK to close the dialog box

and generate the schematic.
3- A status window appears to confirm the schematic generated.
4- A schematic window appears wherein you will find the synchronized circuit.  If the components are not connected, then

steps 1 through 4 will have to be repeated until all components are transferred into the schematic.
5- Add the termination ports to the circuit, and you may perform any tests and simulations.

4.2 To save and close the layout design window:

I. To Save the layout:
1. Click on File in the layout window.
2. Select Save Design and a confirmation window appears, or you may use the Save The Current Deign button on the

tool bar.
3. Click OK to save the changes.

Note: If the layout is generated from the schematic by following the steps in section 4.1.1, ADS saves the name of the layout
file under the same as that of the schematic file.  You may see the two files (schematic and layout) under the file tree in the
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ADS main window, but if you will only see one file name under the Open Design browser.  The schematic window will
open the schematic file, and the layout window will open the layout file.

II. To use Save Design As for a new layout:
1. Click on File in the layout design window.
2. Select Save Design As and a rename window appears.
3. Type the new name.
4. Click OK to save the changes.

III. To Close the layout design:
1. Click on File in the layout window.
2. Select Close Design and the layout design closes.

IV. To Close the layout window:
Click on the little horizontal bar in the upper left corner, and choose Close from the drop-down menu.  Or double click on

the little horizontal bar in the upper left corner, and the window will close.

4.3 Creating a Layout for a Patch Antenna (a schematic is not needed):

1. Create a new project if necessary by following the steps given under section 1.3, Creating a Project.
2. Open a new layout design window by clicking on the New Layout Window icon or by choosing Window>New Layout in

the main ADS window.
3. To set the units of the components used in the layout window, select Options>Preferences and choose the Units/Scale tab.

Then choose the desired units.  Click Apply and then OK.
4. To set the units of the grid in the layout window, select Options>Prefernces and choose the Layout Units tab.  Choose the

desired units and click Apply then OK.  The unit will change at the bottom of the layout window.
5. To adjust the grid spacing, select Options>Preferences and choose the Grid/Snap tab.  Adjust the x and y Snap Grid

spacing as desired in order to get a reasonably spaced grid.
6. In the layout window, click on the View All icon to bring the (0,0) coordinates (the bold + sign) to the middle of the screen.
7. Click on the icon Create a new polygon (has yellow shade), a ghost of cross wires with the pointer will appear.
8. Choose Insert>Coordinate Entry.  Make sure you have adjusted the layout units as explained in step 4.
9. Start your polygon at (0,0) on the XY plane by entering 0 in each of the X and Y fields, then click Apply.  Continue to enter

the coordinates of each of the vertices of the polygon, and click Apply after each entry.
10. When the polygon is complete, drag the axis to the last entered point and click on it – this will display the patch.

Steps 8 through 10 can be drawn differently: Click anywhere on the layout grid.  This will reset the measurement point to (0,0) at
the bottom of the screen.  Then move the pointer towards the desired location.  You will see the measurement on the bottom of
the layout window change, as the pointer is moving.  Stop moving the pointer when the desired measurement is read, and click.
This will set a vertex and create the first side of the patch.  Then move the pointer again to create the second side and set another
vertex.  Repeat until you have reached the starting point.  Double-click on the starting point, and this will display the patch.  Press
<ESC> or deselect the Create a new polygon button to end the command.
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5 PRINTING

The following procedures for printing in ADS hold true in the schematic window, layout window, data display window, and any
other window.

1. In any window, click on File and select Print, or you may select the Print The Current Design button from the tool bar.  A
Print window pops up.  The printer selected in the Printer field is Generic PostScript Printer to FILE:  Select or deselect
Fit page according to what is needed, and click OK – a Print To File window pops up.

2. In the Print To File window, type in any name you want with the extension “eps”.  Example, filename.eps.
3. Then go to the Terminal window, a message will be displayed indicating that a print job has been issued or requested.  This

message also indicates the folder in which the file to be printed was saved.
4. Press the Return key and, if necessary, type in the path of the directory where the file is saved.  Then type lp filename.eps.

The system will display the printer that received the print job – usually the laser printer in Jobst 243.

Note: One has the option of printing only a selected area of a drawing or selected plots.  In the Schematic and Layout windows,
select File>Print Area.  A ghost of cross wires appears as you move the pointer to highlight the desired section of the circuit.  In
the Data Display window, highlight the desired plots to be printed (follow step 3 in section 2.3.5.3 to highlight more than one
plot).  Then select File>Print Selected.

Note: The layout printout saved as a .eps file is used for imaging in order to make negatives of the circuit to be fabricated.  It
must be strongly specified to the imaging company that the layout must be as dark as possible – 100% pitch black.

6 TUNING AN RF CIRCUIT

Tuning is used to slightly modify any component parameter(s) in a circuit that will help in improving simulation results – S-
parameters, noise figure, or any other result.  Therefore, the circuit must be simulated prior to tuning! Tuning (or optimizing)
a circuit during simulation can save the time of several unnecessary fabrication runs to test the circuit for the effects of different
component (or component parameter) values.  The following procedure may be used to tune a circuit:

1. In the schematic window (where the circuit exists), click on the Tune Parameters icon (looks like a tune-fork).  Two
windows will pop up, a Simulation-Status window and a Tune Control window.  Also a ghost of cross wires along with the
pointer will appear in the schematic window as the pointer is moved in the schematic area.

2. Direct the pointer with the axis to the parameter of the component that needs to be tuned and click on that parameter.  The
component as well as the parameter will be surrounded with a red box.  The name and value of the selected parameter
appears in the Tune Control window.

3. You may select more than one parameter at a time.  It is advisable to observe the effects of tuning one parameter at a time if
more than one parameter is selected.

4. In the Tune Control window, select the Simulate drop-down menu and choose After Pressing Tune, that way the circuit
won’t be effected by the changes made until you click on Tune.  Do not change the parameter value yet.

5. If the Data Display window is closed, open a New Data Display window from the schematic window, or simulate the circuit
to automatically open a Data Display window.

6. In the Data Display window, select the simulation parameters (plots of S-parameters, noise figure, etc.) that you would like to
see effected by tuning the component parameter value.

7. In the Tune Control window change the value of the selected component parameter and click Tune.  You may change the
step size, min/max values of the selected parameters to be tuned, and the scaling of the plot by selecting Details.  By default,
the Tune Control window shows the Brief display.

8. Observe the extra trace(s) on the graph(s) in the Data Display window.  The red trace is always the very first simulation
before tuning.  The trace with the new color is the last run.  If a marker was on the original trace, it will move to the latest
trace after tuning.

9. The Trace History field has a default number of 7.  This number indicates the maximum number of traces to be displayed in
the plot.
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10. If the results obtained are satisfactory, click Update in the Tune Control window and save the changes produced in the
schematic.

11. When tuning is completed, click on Cancel in the Tune Control window.  The Tune Control window closes, and the last
trace remains in the plot while all other traces disappear.

7 VARIABLES AND EQUATIONS

Variables and equations may be used to define different component parameters in terms of other component parameters OR to
display different simulated data in terms of other data.

7.1 Using Variables and Equations in the Schematic Window:

1. In the schematic window, click on the “VAR” (variable) icon next to the ground icon.  A ghost image will appear in the
drawing area.  Place it where desired.

2. Double-click on the VAR box to open the parameter dialog box, called Variables & equations.
3. In the Variables & equations dialog box, you will see a variable X with its value 1.
4. In the Name field type the desired variable name (e.g. L1 or W1), and enter its corresponding value in the Variable Value

field (e.g. 0.15).  Then click Add to add it to the parameter list (under X).
5. Select the variable X=1.0 and click Cut to delete it.
6. Then add the second variable using a similar fashion as that used for the first variable (e.g. L2 or W2 with the corresponding

values).
7. Enter the name of the third variable in the Name field (e.g. L3 or W3).  Now if the third variable is represented by an

equation in terms of the first two variables, then enter the corresponding equation in the Variable Value field (e.g.
L3=L1+L2).  Any equation may be used.  Click Add to add it to the list.  And finally, click Apply then OK.

8. In the schematic window, click on the corresponding components’ parameters that are to be replaced with the previously
defined variables.  Specify the units within the component’s parameter.

9. Be sure to re-simulate the circuit so that the modifications will take effect on the test data.

Note: This procedure can be performed for as many variables as needed.
You may also edit the parameter values within VAR by double clicking on the parameter to be modified.  The value field turns
red and a cursor appears.  When done, press Return or click anywhere in the schematic window or press <ESC> to end the
command.

7.2 Using Equations in the Data Display Window:

1. In the Data Display window, after plotting the desired S-parameters, noise figures, or any other parameters click on the
equation icon, Eqn. An image of a box will appear in the data display window.  Place the box where desired by clicking and
a dialog box called Enter Equation will pop up.

2. In the Enter Equation window, enter the desired equation.  For example, if a plot of the VSWR is needed, type
“VSWR=(1+” then select the S(1,1) parameter from the adjacent list and click on Insert.  Then type “)/(1-“ and select S(1,1)
from the adjacent list and type “)”.  Then click Apply, and then OK.  The equation will be displayed in the Data Display
window.  Parameters of other data sets may be used by choosing the appropriate data set from the drop-down menu on the
right-hand side of the Enter Equation window.

3. To plot the generated equation, select the appropriate chart type (Rectangular, Smith, Polar etc.).  In the Plot Traces &
Attributes window that pops up, select Equations from the drop-down menu under Datasets & Equations.  Then select the
equation to be plotted (select VSWR in the above example then click Add and choose the appropriate way to display the
data, and click OK then OK).  OR you may add it to an already existing plot by double clicking on the plot and following the
same procedure.

Note: If the word Eqn displayed in front of the actual equation is highlighted with red, it means that the equation is wrong.
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7.3 Using the Measurement Equation in the Schematic Window:

The measurement equation (MeasEqn) feature is similar to both VAR and Eqn.  It is similar to VAR in which it is included in
the schematic window, yet it is similar to Eqn in which one can plot a particular equation after simulating the circuit.  In the case
of MeasEqn, the equation created is a part of the data set of the circuit simulated and not Equations.  That is, the created
equation will appear in the Plot Traces & Attributes window as part of the data set of the simulated circuit.

MeasEqn is found in any of the simulation component palettes (S_Param, DC, AC etc.).  After placing MeasEqn in the
schematic area, one can create (or modify) as many equations needed in a similar fashion as one would handle VAR.  The edit
window for MeasEqn is called simulation measurement equation.

Using the VSWR example, enter the equation VSWR=(1+S(1,1))/(1-S(1,1)) in the simulation measurement equation window.
Then simulate the circuit.  In the Data Display window, choose the appropriate chart type.  In the Plot Traces & Attributes
window, select VSWR and Add it to the Traces column and click OK (choose the appropriate way to display the data and click
OK).  The VSWR trace will be displayed.
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8 MULTIPLE PLOT GENERATION

Multiple plot generation is useful when we would like to plot two graphs on the same chart.  It is very useful in graphical
comparison of simulated and measured data, i.e. generation of measured and simulated plots on the same grid.  This section gives
an example of generating measured and simulated results on the same graph.

STEP1: Simulate the circuit as described in section 3.  Let the circuit schematic file name and data set be CKT_1.

STEP2: Create an S-parameter file (.S2P) with the measured S-parameters.  Save this file in the data sub directory of your
project.  You may use file manager to do this.  The file can be created using “Pico” editor, “Vi” editor, or any other text editor
like “Notepad”. An example .S2P file is given following Note 3.

Note1:  The lines starting with exclamation mark (!) in the .S2P file are comments.  Also, Correct format must be followed
while creating the .S2P file.  The usual format used is:
# Frequency-unit  S  MA  R  Reference-Impedance
Example:
# GHz  S  MA  R  50

‘S’ in the above statement stands for S-parameters,
‘MA’ stands for Magnitude and Angle, and
‘R’ stands for reference impedance.

The data must be entered in the following order:
Frequency   mag(S11)  Ang(S11)  mag(S21)  Ang(S21)  mag(S12)  Ang(S12)  mag(S22)  Ang(S22)

Note 2: The noise data shown in the example of .S2P file is optional.  It need not be included in your .S2P file when your goal is
to plot the measured vs. simulated S-parameters.

Note 3: If the noise data is also to be included, then it must follow immediately in the next control line of the .S2P file after the S-
parameter data.  I.e. the S-parameter data and Noise data can be separated by a blank line or a comment line as shown in the
example file.

The order for the Noise data:
Frequency     NFmin     Γopt(mag)   Γopt(ang)     rn (Normalized with 50Ω)

EXMPLE OF .S2P file:
! SCCS file tdata/nec: @(#)get -r1.1 /eesof/src/tdata/nec/s.n34018.s2p #
!Version date: 5/3/90~*/
! FILENAME:        N04500A.S2P          VERSION: 1.0
! NEC PART NUMBER: NE04500              DATE:    6/85
! BIAS CONDITIONS: VDS=2V    ID=10MA
! NOTE:       S-PARAMETERS DO NOT INCLUDE BOND WIRES
# GHZ S MA R 50
 0.5 0.978 -17.0 6.806 162.8 0.018 80.1 0.723 -7.5
 0.6 0.969 -20.3 6.731 159.7 0.022 78.7 0.719 -9.1
 0.7 0.960 -23.6 6.691 156.5 0.025 77.3 0.712 -10.5
 0.8 0.949 -26.9 6.624 153.4 0.028 75.5 0.706 -12.0
 0.9 0.938 -30.1 6.559 150.3 0.032 73.6 0.698 -13.4
 1.0 0.924 -33.3 6.502 147.2 0.035 72.4 0.690 -14.9
 1.2  0.897 -39.8 6.371 141.2 0.041 69.2 0.673 -17.8
 1.4 0.865 -46.0 6.217 135.3 0.047 66.3 0.655 -20.6
 1.6 0.831 -52.4 6.065 129.5 0.053 63.4 0.635 -23.4
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 1.8 0.796 -58.7 5.912 123.9 0.058 60.7 0.614 -26.1
 2.0 0.757 -65.1 5.750 118.3 0.063 58.1 0.594 -28.8
 2.5 0.658 -81.9 5.336 105.0 0.074 51.7 0.546 -35.3
 3.0 0.563 -100.1 4.909 92.4 0.083 46.5 0.501 -41.2
 3.5 0.483 -119.7 4.478 80.8 0.091 41.8 0.463 -45.9
 4.0 0.432 -139.4 4.080 70.2 0.097 38.1 0.429 -49.5
 4.5 0.409 -157.2 3.733 60.8 0.103 35.1 0.388 -53.3
 5.0 0.406 -171.0 3.448 52.3 0.109 33.2 0.363 -53.8

! NOISE DATA    12/85
0.9 .56 0.76 30 .45
2 .63 .61 41 .28
2.5 .68 .49 51 .18
3 .7 .39 49 .16
4 .82 .2 80 .1

STEP 3: Create a new circuit file in the schematic window as shown in the following figure:

Your circuit must contain the S-parameter block that corresponds to the .S2P file created in Step 2.  To create the S-parameter
block, do the following:

a) In the new schematic window, select Data Items from the Component Palette List.
b) Select the button S2P: 2-port S-parameter file from the component palette on the left-hand-side.
c) Move the pointer into the drawing area.  As you move the pointer, you will see the ghost image of the component moving

along with the pointer.  Click in the desired location in the drawing area to place the component.
d) After placing the component in the desired location, double click on the component.  A 2-Port S-parameter File dialog box

pops up.
e) Specify the corresponding S-parameter file for the file parameter in the dialog box.  You can also browse and select the

desired file.  To browse for a file, click on the Browse button in the dialog box.  A selection window appears where you can
select the desired file.

Note: If the desired .S2P file is present in the data subdirectory of any project, which is not the current project, you can still
select the file by using the browse button.

f) Click Apply then OK in the 2-Port S-parameter File dialog box.
g) Place the Term components and the S-Parameter Simulation component from the component palette for simulating the S-

parameter block.

S2

Term
Num=2

Term
Num=1
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h) Save this file with a name different from the original circuit name whose simulated results have to be compared.  Suppose
this schematic file name and data set is CKT_2.

STEP 4: Simulate the circuit created in step 3; i.e. data set CKT_2.  The Data Display window automatically appears.

STEP 5: Select the desired chart type (rectangular, Smith, polar etc.), and click on the drawing area.  A Plot Traces &
Attributes window pops up.

STEP 6: Select the original circuit’s (whose simulated results are to be compared) data set from the Datasets and equations
combo box.  In this example, the data set is CKT_1.

STEP 7: Select the desired data that are to be compared and add them to the Traces column using Add and Delete buttons.

STEP 8: Select the S-parameter block (created in step 3) data set (which has the measured results) from the Datasets and
equations combo box.  In this example, the data set is CKT_2.

STEP 9: Select the desired data that are to be compared and add them to the Traces column using Add and Delete buttons.

STEP 10: Click OK to get the chart containing measured and simulated results.


