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University of California, Berkeley Spring 2025 
EECS 142/242A Prof. A. Niknejad 

 

Lab 0: ADS Tutorial and Lab Introduction 
 

In this lab you will get familiar with Agilent ADS, the main simulation tool that we will use in this 
class. You will also get an introduction to some of the lab measurement equipment, and hands-on 
experience working with transmission lines in the time domain. 

We highly recommend that you download and install your own local copy of ADS.  You can 
do this on Windows, Linux, and a Mac PC with an Intel CPU (provided you run a virtual machine).  
Alternatively, you can follow the instructions below to setup a class account. 

1. Creating a user account 
If you are enrolled in the course, please visit: http://inst.eecs.berkeley.edu/webacct. This should 
also work if you are on a waitlist. 

2. Connecting using the instructional accounts 
In addition to the 142 lab computers, ADS is installed on the eda servers. 

For running the graphics remotely (from Windows or Mac) the following tools are recommended: 

1. X2Go: http://wiki.x2go.org/doku.php/download:start 
You don't need to have a key for this client. 

- If the download doesn’t show up, that likely means your browser is complaining 
about the security issues with the executable. For Google, click the three dots and 
click downloads. Click “Keep dangerous file”. Run this file to install. 

- Once installed, you can connect to the eda servers 1 through 8 to access the 
instructional machines for this class by entering “eda-#.eecs.berkeley.edu” for the 
host name, and your instructional account login. 

- When connecting, make sure to select "session type" as "MATE". (Nomachine is 
not supported on those servers for now.) 

- If you are trying to connect from your home network, make sure you connect to the 
Berkeley VPN. 

http://inst.eecs.berkeley.edu/webacct
http://wiki.x2go.org/doku.php/download:start
https://security.berkeley.edu/services/bsecure/bsecure-remote-access-vpn
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After connecting, open a terminal and type "ads" to start the program. 

At the first time you run the program, the following window will appear: 
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Choose the first option (ADS All inclusive) and check the "Always try to start Advanced Design 
System with this selection" to remove this window for the next times. 

3. ADS overview 
When opening ADS, you'll see the main window: 

 

The designs in ADS are combined under "workspaces". Each workspace can contain multiple 
design schematics. To open a new workspace: File -> New -> Workspace. The workspace name 
should end with _wrk and cannot contain spaces: 
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Click Finish in this window to create the workspace. 
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To add a schematic to the workspace, click on "New schematic window": 

 

The "Cell" is the name for the schematic. 

Below is the main schematic window: 

 

The most useful buttons are annotated above. 

To add a component, choose the appropriate category and click on the component on the left side 
of the screen. 
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In ADS, simulation setups and variables are also added to the schematic as components. 

Useful components: 

Category Components 

Lumped-Components 

R,L,C 
DCfeed - infinite inductor 
DCBlock - infinite capacitor 
TF, TF3 - transformers 

Sources-Controlled VCVS, VCCS, ... 

Sources-Freq Domain V_DC, I_DC - DC sources 
V_AC, I_AC - AC sources (for AC simulation) 

Sources-Time Domain Sine, Pulse - for transient simulations 
Simulation-DC DC - DC simulation 
Simulation-AC AC - AC simulation 
Simulation-Transient Trans - Transient simulation 

Any simulation category PrmSwp - Parametric sweep 
Sweep Plan - setup parameters for parametric sweep 

Probe Components I_probe - current probe 
TLines – Ideal Ideal transmission lines 

Devices - BJT BJTNPN, BJTPNP - bipolar transistors 
BJT - transistor model 

Devices - MOS 

NMOS, PMOS - MOS transistors for level1-level3 spice 
models 
Level 1, Level 2, Level 3 - spice models 
Bsim 4 (N,P) - MOS transistors for BSIM4 models 
Bsim4 (M) - BSIM4 model 
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4. Simulating a transmission line in the time domain in ADS 
Add an ideal transmission line (“TLIN” in the “TLines-Ideal” component category) to your 
schematic.  

 

There are three parameters: Z, E, and F. Z represents the characteristic impedance of the 
transmission line, and E represents the “electrical length” at frequency F. Basically, E represents 
the phase shift (in degrees) that a sine wave at frequency F will undergo, for this length of 
transmission line. 

Going back to the time domain, we can compute the delay of the transmission line from E and F: 

Tdelay = 1/F × E ÷ 360. 

So, the default ADS transmission line parameters represent a 50-ohm transmission line with a 
delay of 250ps. 

To verify this, we will perform a transient simulation of a pulse traveling along this transmission 
line. Add a “VtStep” source from “Sources-Time Domain” to the schematic. Set the “Delay” 
parameter to 1 nanosecond, and the “Rise” parameter to 50 picoseconds. You can edit the 
parameters by double-clicking on the VtStep source. 
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Also, we will want to add a source and load resistor. Place two resistors from “Lumped-
Components” (just the simple “R”, R_model is not needed here) as shown in the screenshot below. 
You can rotate the components before placing using Ctrl-R.  

 

The default resistance is set to 50ohms, so we won’t need to modify it for this simulation. 

We also need to add wires and grounds.  

In ADS, grounds represent an ideal “ground” connection with a potential of 0 volts, and zero 
impedance. They can be creating using the menu Insert->Ground, or by clicking the Ground button 
on the toolbar (circled in blue above). 

Wires are used to connect components in the schematic. They can be creating using the menu 
Insert->Wire, clicking the Wire button on the toolbar (circled in red above), or with the keyboard 
shortcut Ctrl-W. 
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Connect the remaining components as shown below: 

 

Before simulating, we should label the important nets in the circuit. We can do this by adding a 

label by clicking Insert->Wire/Pin Label, or by clicking the toolbar button:  

Label the three nodes of the circuit “vSrc”, “vTLineLeft”, and “vTLineRight” (going from left to 
right). 

Finally, we need to add a simulation setup. Select the “Simulation-Transient” category and place 
a “Trans” simulation setup. Set the MaxTimeStep to 10psec, and the StopTime to 2 nsec. 

 

  



10 
 

Now your schematic should look like this: 

 

You can run the simulation by clicking the gear icon on the toolbar:  

When it finishes, a simulation results window will pop up: 

 

 

 

Add 
markers 

 Add plots 
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On the left you can see different types of plots that you can choose from. The most useful are: 

 
Rectangular plot 

 

 
Smith chart (we'll study it later 
on in this class) 

 
List (a table) 

 

 
Defining output equations 

 

For now, we will create a rectangular plot to view the voltages on the three nodes. When you place 
a rectangular plot item in the results window, it will prompt you for traces to plot. Select the three 
node voltages as shown below: 

 

Then click “>>Add>>”, then “OK”.  
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You should end up with a graph showing three step functions: 

 

As expected, there is 250ps of delay from one end of the transmission line to the other. However, 
nothing really too interesting is happening here, because all the impedances are matched in the 
system.  

5. Parameter sweeps in ADS 
What happens if we change the load resistance from 50ohms? We can manually change this and 
observe the results, but ADS will also let you sweep component values or design parameters and 
plot the results on the same axis. 

First, we need to change the load resistance value to be parameterized. Instead of 50 Ohms, type 
in “RL” (without quotes) as the load resistance value. The units will change to “none” to 
acknowledge that you are using a variable rather than a fixed numeric value. 

We will need to place a Variable Equation to define the load resistance:  in the toolbar. 

Make a variable “RL” with a value of 50.  

Finally, insert a “PrmSwp” from the “Simulation-Transient” category. Set the SweepVar to RL, 
and make it a Linear sweep from 10 to 100 with step size 10.  
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Also, enter the name of the transient simulation you want the sweep to apply to in the 
“Simulations” tab of the parameter sweep item. The default transient simulation name should be 
“Tran1”, just double check with yours to be sure. The new simulation setup should look like this: 

 

Now run the simulation again and plot the outputs. You might want to delete all but one trace from 
the plot, so the results are easier to see. Here is an example set of waveforms from the “vTLineLeft” 
trace: 

 

You can extend the simulation time to verify that there are no more reflections beyond 2ns. Can 
you explain why this is the case? 



14 
 

6. Multiple reflections in transmission lines 
Ok, now we are going to disable the parameter sweep, by selecting it and clicking the “disable 

components” toolbar button:  

 

You should also create a variable for the source resistance, RS. Set RS=120, and RL = 10.  

 

Now re-run the simulation. The resulting load voltage would look a little strange, if you don’t 
know that transmission line effects are playing a role: 
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7. Transmission line mismatch experiment  
(this is borrowed from EE117, so sorry if you’ve seen this before) 

In this experiment you will observe reflection and transmission of incident pulses as they propagate 
down a coaxial transmission line. You will observe the effects of matched and mismatched 
termination impedances on the amplitude and sign of the reflected pulses. By measuring the time 
between the arrival of the incident and reflected pulses, you will calculate the length of the line. 
By varying the pulse width you will observe the superposition of the incident and reflected pulses. 

 

The following diagram shows the experiment setup. This should mostly already be assembled 
when you go into the lab, but double check with the GSI before running the experiment. 

 

 

There should be a range of termination resistances for the interchangeable load, from short circuit 
to 100ohms. Record the pulse waveform from the oscilloscope for short circuit, 10 ohm, 50 ohm, 
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and 100ohm loads. You can sketch the waveform by hand, or use your phone to take a picture of 
the oscilloscope trace. 

With an open circuit load (nothing attached end of cables), vary the pulse width of the signal 
generator. Record several of these waveforms, making note of the pulse width in each case. 

8. ADS model 
With the background from the ADS tutorial, you can recreate this experiment in simulation using 
ideal transmission lines. Since real transmission lines have some loss, you may not be able to 
replicate things perfectly. Also, be sure to consider the input and output impedances of the signal 
generator and oscilloscope when constructing your model. 

While you can complete this outside of the lab, we suggest that you finish up the simulation during 
the rest of the lab time. That way, if you have any additional questions, you can bring them up 
with your GSI. 

9. Lab writeup 
For your lab group, please submit: 

● Waveforms from each of the load impedances connected from part (7) 
o Explanations of the waveform behavior in each case 

● Waveforms from when the pulse width is varied 
o Explanations of the waveform behavior in each case 

● ADS simulation schematics for the experiment model 
● ADS simulation results 
● A paragraph comparing simulation results to your measurements. 

 

 

 

 


